Zigbee2mqtt integration

Hi again,
I am running zigbee2mqtt service to control Zigbee switch plug. It works and I can see state is changing.
Now I am trying to integrate zigbee2mqtt with Gladys.

and on the server side I got an error message:

2023-05-25T08:29:19+0200 <debug> zigbee2mqtt.controller.js:22 (getManagedAdapters) Get managed adapters
2023-05-25T08:29:19+0200 <debug> zigbee2mqtt.controller.js:33 (status) Get status
2023-05-25T08:29:23+0200 <debug> zigbee2mqtt.controller.js:44 (setup) Entering setup step
2023-05-25T08:29:23+0200 <trace> errorMiddleware.js:49 (errorMiddleware) PlatformNotCompatible [Error]: SYSTEM_NOT_RUNNING_DOCKER 

P.S. I am running Gladys in development environment:

Hey @sigidagi :slight_smile:

Currently, we do not support connecting to an existing Zigbee2mqtt container in Gladys, we only support starting a Zigbee2mqtt Docker container from Gladys (hence the Docker requirements)

As you are running Gladys in a developpement environnement (and not from inside the official Docker container), this integration will not work

For the future, @atrovato is working on making it possible to connect to external already-existing Zigbee2mqtt instances :wink:

Hi @pierre-gilles
Thanks for your answer,
Ok, I disable local zigbe2mqqt and installed gladys docker. It is running and I have three containers: gladys, mqqt broker and zigbee2mgtt.
Added Philips switch.

As far as good.
But UI is not that intuitive. I was expecting some toggle button to able to control this switch device. Where I can find it?
P.S. Zigbee2Mqtt frontend was working but I needed more nicer UI (also for mobile phone), so I was looking for gladys :slight_smile:

Go to the dashboard (home) and add a box « devices in room » with that device :slight_smile:

Note: your device needs to be defined in a room in the Zigbee2mqtt integration

Thanks @pierre-gilles ,
Yes I have added room and device to that room - I have now toggle button!

I can see that mqtt broker exposes 1884 port, so I would like to publish some other (not zigbee) devices to the broker, i.e. temperature sensor data. I expect that Gladys will recognize as another Zigbee2mqqt device?
I have tried to test connection:

mosquitto_sub -p 1884 -t '#'

Connection refused: not authorized.

What is username and password?


If you want to do that, use the MQTT integration and our MQTT API :slight_smile:

Follow this tutorial to do that :